Skip to content
Navigation Menu
Sign in
Appearance settings
Platform
AI CODE CREATION
GitHub Copilot
Write better code with AI
GitHub Copilot app
Direct agents from issue to merge
MCP Registry
Integrate external tools
DEVELOPER WORKFLOWS
Actions
Automate any workflow
Codespaces
Instant dev environments
Issues
Plan and track work
Code Review
Manage code changes
Code Quality
Enforce quality at merge
APPLICATION SECURITY
GitHub Advanced Security
Find and fix vulnerabilities
Code security
Secure your code as you build
Secret protection
Stop leaks before they start
EXPLORE
Why GitHub
Documentation
Blog
Changelog
Marketplace
View all features
Solutions
BY COMPANY SIZE
Enterprises
Small and medium teams
Startups
Nonprofits
BY USE CASE
App Modernization
DevSecOps
DevOps
CI/CD
View all use cases
BY INDUSTRY
Healthcare
Financial services
Manufacturing
Government
View all industries
View all solutions
Resources
EXPLORE BY TOPIC
AI
Software Development
DevOps
Security
View all topics
EXPLORE BY TYPE
Customer stories
Events & webinars
Ebooks & reports
Business insights
GitHub Skills
SUPPORT & SERVICES
Documentation
Customer support
Community forum
Trust center
Partners
View all resources
Open Source
COMMUNITY
GitHub Sponsors
Fund open source developers
PROGRAMS
Security Lab
Maintainer Community
GitHub Stars
Archive Program
REPOSITORIES
Topics
Trending
Collections
Enterprise
ENTERPRISE SOLUTIONS
Enterprise platform
AI-powered developer platform
AVAILABLE ADD-ONS
GitHub Advanced Security
Enterprise-grade security features
Copilot for Business
Enterprise-grade AI features
Premium Support
Enterprise-grade 24/7 support
Pricing
Search
/
Sign in
Sign up
Appearance settings
You signed in with another tab or window.
Reload
to refresh your session.
You signed out in another tab or window.
Reload
to refresh your session.
You switched accounts on another tab or window.
Reload
to refresh your session.
Dismiss alert
{{ message }}
pyca
verified-garbage
Repository navigation
Code
Issues
8
(8)
Pull requests
35
(35)
Actions
Security and quality
Insights
More
items
All pull requests
New pull request
Search pull requests
is
:
pr
state
:
open
is:pr state:open
Clear filter
Search
Pull requests
Open
35
(35)
Closed
1,270
(1,270)
Author
Label
Projects
Milestones
Reviews
Assignee
Sort by
Newest
descending
Sort…
Sort by Newest descending
More items
Comfortable display density
Compact display density
x86-64 RSA CRT: 2^E mod n in one multiplication (up to 4.7% faster private-key operations)
#1357
·
alex
opened
Oct 8, 2026
Member
·
·
Camellia (RFC 3713) key schedule and ECB on x86-64
#1356
·
reaperhulk
opened
Oct 8, 2026
Member
·
·
x86-64 RSA: vg_rsa_check_crt_key, and PrivateKey::from_crt checks keys with it (17–29× faster loading)
#1355
·
alex
opened
Oct 8, 2026
Member
·
·
AES-GCM on x86-64: encrypt copies a short text and seals it in place
#1354
·
alex
opened
Oct 8, 2026
Member
·
·
x86-64 P-521: field products by calls of vg_p521_mul_mod_p
#1353
·
alex
opened
Oct 8, 2026
Member
·
·
Benchmarks: RSA key loading from the CRT values (rsa_from_crt)
#1352
·
alex
opened
Oct 8, 2026
Member
·
·
x86-64 AES-GCM: seal_gather copies a short text and seals it in place
#1350
·
alex
opened
Oct 8, 2026
Member
·
·
1
Blowfish-ECB on x86-64: verified key expansion and ECB
#1346
·
reaperhulk
opened
Oct 8, 2026
Member
·
·
Verified SEED-ECB and key expansion on AArch64
#1344
·
reaperhulk
opened
Oct 8, 2026
Member
·
·
RSA spec: RSA_check_key's checks of the CRT form, without d (vg_rsa_check_crt_key)
#1343
·
alex
opened
Oct 8, 2026
Member
·
·
Add verified secp256k1 support on AArch64
#1342
·
reaperhulk
opened
Oct 8, 2026
Member
·
·
Add verified secp256k1 support on x86-64
#1341
·
reaperhulk
opened
Oct 8, 2026
Member
·
·
Generalize elliptic-curve proofs for secp256k1
#1340
·
reaperhulk
opened
Oct 8, 2026
Member
·
·
Verified SEED-ECB and key expansion on x86-64
#1335
·
reaperhulk
opened
Oct 8, 2026
Member
·
·
AArch64 CAST5 ECB: key expansion and ECB by full table scans in AdvSIMD
#1334
·
reaperhulk
opened
Oct 8, 2026
Member
·
·
Blowfish-ECB on AArch64: verified key expansion and ECB
#1332
·
reaperhulk
opened
Oct 8, 2026
Member
·
·
Speed up AVX-512 AES-GCM TLS records with prepared keys and direct gather
#1331
·
reaperhulk
opened
Oct 8, 2026
Member
·
·
1
x86-64 CAST5 ECB: key expansion and ECB by full table scans in SSE2
#1328
·
reaperhulk
opened
Oct 8, 2026
Member
·
·
AArch64: verified IDEA key schedules and ECB
#1327
·
reaperhulk
opened
Oct 8, 2026
Member
·
·
x86-64: verified IDEA key schedules and ECB
#1326
·
reaperhulk
opened
Oct 8, 2026
Member
·
·
Specify Camellia (RFC 3713) and its ECB contracts
#1323
·
reaperhulk
opened
Oct 8, 2026
Member
·
·
Spec: CAST5 (CAST-128, RFC 2144) ECB with 40- to 128-bit keys
#1322
·
reaperhulk
opened
Oct 8, 2026
Member
·
·
Specify SEED (RFC 4269) and its ECB contracts
#1321
·
reaperhulk
opened
Oct 8, 2026
Member
·
·
Spec: IDEA (Lai 1992) and ECB on whole blocks
#1320
·
reaperhulk
opened
Oct 8, 2026
Member
·
·
Specify Blowfish ECB and its contracts
#1318
·
reaperhulk
opened
Oct 8, 2026
Member
·
·
Previous
1
2
Next
You can’t perform that action at this time.