Skip to content
Merged
Show file tree
Hide file tree
Changes from all commits
Commits
Show all changes
23 commits
Select commit Hold shift + click to select a range
ee4d6e8
Cronjob - daily check of IETF modules.
jclarke-csco Oct 5, 2026
7bb0747
Merge branch 'main' of https://github.com/YangModels/yang into fork-main
jclarke-csco Oct 6, 2026
ed80272
Cronjob - daily check of IETF modules.
jclarke-csco Oct 6, 2026
a76e18d
Cronjob - daily check of IETF modules.
jclarke-csco Oct 8, 2026
5300a8d
Cronjob - daily check of IETF modules.
jclarke-csco Oct 9, 2026
772cef0
Cronjob - daily check of IANA modules.
jclarke-csco Oct 10, 2026
83cf72c
Cronjob - daily check of IETF modules.
jclarke-csco Oct 11, 2026
0e13201
Cronjob - daily check of IANA modules.
jclarke-csco Oct 14, 2026
c67c385
Cronjob - daily check of IETF modules.
jclarke-csco Oct 15, 2026
830bc35
Cronjob - daily check of IETF modules.
jclarke-csco Oct 16, 2026
8a49de0
Cronjob - daily check of IANA modules.
jclarke-csco Oct 17, 2026
accaf25
Cronjob - daily check of IETF modules.
jclarke-csco Oct 18, 2026
962e6b0
Cronjob - daily check of IETF modules.
jclarke-csco Oct 20, 2026
55e653f
Merge branch 'main' of https://github.com/YangModels/yang into fork-main
jclarke-csco Oct 21, 2026
7522e24
Cronjob - daily check of IETF modules.
jclarke-csco Oct 21, 2026
4717c8a
Cronjob - daily check of IETF modules.
jclarke-csco Oct 22, 2026
d891423
Cronjob - daily check of IETF modules.
jclarke-csco Oct 23, 2026
203d235
Cronjob - daily check of IANA modules.
jclarke-csco Oct 24, 2026
085e368
Cronjob - daily check of IETF modules.
jclarke-csco Oct 25, 2026
fcb9c05
Cronjob - daily check of IETF modules.
jclarke-csco Oct 26, 2026
52f209c
Cronjob - daily check of IETF modules.
jclarke-csco Oct 27, 2026
d482545
Cronjob - daily check of IANA modules.
jclarke-csco Oct 30, 2026
be69000
Cronjob - daily check of IETF modules.
jclarke-csco Oct 30, 2026
File filter

Filter by extension

Filter by extension

Conversations
Failed to load comments.
Loading
Jump to
Jump to file
Failed to load files.
Loading
Diff view
Diff view
Original file line number Diff line number Diff line change
Expand Up @@ -25,7 +25,6 @@ module iana-bgp-afi-safi-types {
Keyur Patel (keyur at arrcus.com),
Susan Hares (shares at ndzh.com),
Jeffrey Haas (jeffrey.haas at hpe.com).";

description
"This YANG module is maintained by IANA and contains identity
definitions for BGP AFI/SAFI types. It reflects the 'Address
Expand Down Expand Up @@ -55,7 +54,7 @@ module iana-bgp-afi-safi-types {
described in BCP 14 (RFC 2119) (RFC 8174) when, and only when,
they appear in all capitals, as shown here.";

revision 2026-08-14 {
revision 2026-10-16 {
description
"Initial Version";
ysv:version 0.0.9;
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -13,7 +13,6 @@ module iana-bgp-capabilities {
"IANA";
contact
"Internet Assigned Numbers Authority

Postal: ICANN
12025 Waterfront Drive, Suite 300
Los Angeles, CA 90094-2536
Expand Down Expand Up @@ -54,7 +53,7 @@ module iana-bgp-capabilities {
described in BCP 14 (RFC 2119) (RFC 8174) when, and only when,
they appear in all capitals, as shown here.";

revision 2026-08-14 {
revision 2026-10-16 {
description
"Initial Version";
ysv:version 0.0.9;
Expand All @@ -72,6 +71,7 @@ module iana-bgp-capabilities {
description
"Base identity for a BGP capability";
}

identity mp-bgp {
base bgp-capability;
description
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -57,7 +57,7 @@ module iana-bgp-community-types {
described in BCP 14 (RFC 2119) (RFC 8174) when, and only when,
they appear in all capitals, as shown here.";

revision 2026-08-14 {
revision 2026-10-16 {
description
"Initial Version";
ysv:version 0.0.9;
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -55,7 +55,7 @@ module iana-bgp-notification {
described in BCP 14 (RFC 2119) (RFC 8174) when, and only when,
they appear in all capitals, as shown here.";

revision 2026-08-14 {
revision 2026-10-16 {
description
"Initial Version";
ysv:version 0.0.9;
Expand All @@ -74,6 +74,7 @@ module iana-bgp-notification {
"All errors detected while processing the Message Header MUST
be indicated by sending the NOTIFICATION message with the
Error Code Message Header Error.

The value of the 'Message Header Error' Error code is 1.";
reference
"RFC 4271: A Border Gateway Protocol 4 (BGP-4), Section 6.1.";
Expand Down Expand Up @@ -110,7 +111,6 @@ module iana-bgp-notification {

- if the Length field of the message header is less than 19 or
greater than 4096, or

- if the Length field of an OPEN message is less than the
minimum length of the OPEN message, or

Expand All @@ -122,6 +122,7 @@ module iana-bgp-notification {

- if the Length field of a NOTIFICATION message is less than
the minimum length of the NOTIFICATION message,

then the Error Subcode MUST be set to Bad Message Length. The
Data field MUST contain the erroneous Length field.

Expand Down Expand Up @@ -590,7 +591,6 @@ module iana-bgp-notification {
reference
"RFC 4271: A Border Gateway Protocol 4 (BGP-4), Section 6.7.";
}

identity cease-max-prefixes {
base cease;
description
Expand Down Expand Up @@ -649,6 +649,7 @@ module iana-bgp-notification {
"If a BGP speaker decides to de-configure a peer, then the
speaker SHOULD send a NOTIFICATION message with the Error Code
Cease and the Error Subcode 'Peer De-configured'.

The value of the 'Peer De-configured' Error subcode is 3.";
reference
"RFC 4486: Subcodes for BGP Cease Notification Message, Section
Expand Down Expand Up @@ -782,7 +783,6 @@ module iana-bgp-notification {
RFC 7313: Enhanced Route Refresh Capability for BGP-4, Section
6.";
}

identity route-refresh-invalid-message-length {
base route-refresh-message-error;
description
Expand All @@ -793,6 +793,7 @@ module iana-bgp-notification {
subcode of 'Invalid Message Length'. The Data field of the
NOTIFICATION message MUST contain the complete ROUTE-REFRESH
message.

The value of the 'Invalid Message Length' Error subcode is
1.";
reference
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -56,7 +56,7 @@ module iana-bgp-rib-types {
described in BCP 14 (RFC 2119) (RFC 8174) when, and only when,
they appear in all capitals, as shown here.";

revision 2026-08-14 {
revision 2026-10-16 {
description
"Initial Version";
ysv:version 0.0.9;
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -83,7 +83,7 @@ module ietf-ac-udp-tunnel {
to a group of port numbers.";
container source-port-range-or-operator {
description
"Indicates a set of source ports numbers.";
"Indicates a set of source port numbers.";
uses packet-fields:port-range-or-operator;
}
}
Expand Down
Loading
Loading