Repository navigation
Expand file tree
/
Copy pathResponse.php
More file actions
executable file
·413 lines (368 loc) · 10.3 KB
/
Copy pathResponse.php
File metadata and controls
executable file
·413 lines (368 loc) · 10.3 KB
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
218
219
220
221
222
223
224
225
226
227
228
229
230
231
232
233
234
235
236
237
238
239
240
241
242
243
244
245
246
247
248
249
250
251
252
253
254
255
256
257
258
259
260
261
262
263
264
265
266
267
268
269
270
271
272
273
274
275
276
277
278
279
280
281
282
283
284
285
286
287
288
289
290
291
292
293
294
295
296
297
298
299
300
301
302
303
304
305
306
307
308
309
310
311
312
313
314
315
316
317
318
319
320
321
322
323
324
325
326
327
328
329
330
331
332
333
334
335
336
337
338
339
340
341
342
343
344
345
346
347
348
349
350
351
352
353
354
355
356
357
358
359
360
361
362
363
364
365
366
367
368
369
370
371
372
373
374
375
376
377
378
379
380
381
382
383
384
385
386
387
388
389
390
391
392
393
394
395
396
397
398
399
400
401
402
403
404
405
406
407
408
409
410
411
412
413
<?php
/**
* Webiny Framework (http://www.webiny.com/framework)
*
* @copyright Copyright Webiny LTD
*/
namespace Webiny\Component\Http;
use Webiny\Component\Http\Response\CacheControl;
use Webiny\Component\Http\Response\ResponseException;
use Webiny\Component\StdLib\StdObjectTrait;
/**
* This is the class for building HTTP responses.
*
* @package Webiny\Component\Http\Response
*/
class Response
{
use StdObjectTrait;
const PROTOCOL = 'HTTP/1.1';
const CHARSET = 'UTF-8';
const CONTENT_TYPE = 'text/html';
/**
* @var string Holds the response content that will be rendered on the page.
*/
private $_content;
/**
* @var int Holds the response HTTP status code.
*/
private $_statusCode;
/**
* @var string HTTP response status message;
*/
private $_statusMessage;
/**
* @var string Content type header value.
*/
private $_contentType;
/**
* @var string Holds the header charset information.
*/
private $_charset;
/**
* Holds header information.
*
* @var \Webiny\Component\StdLib\StdObject\ArrayObject\ArrayObject
*/
private $_headers;
private $_cacheControl;
/**
* @var array An array of http status codes by RFC2616 standard or some other if noted by comment.
*/
public static $httpStatuses = array(
100 => 'Continue',
101 => 'Switching Protocols',
102 => 'Processing',
// RFC2518
200 => 'OK',
201 => 'Created',
202 => 'Accepted',
203 => 'Non-Authoritative Information',
204 => 'No Content',
205 => 'Reset Content',
206 => 'Partial Content',
207 => 'Multi-Status',
// RFC4918
208 => 'Already Reported',
// RFC5842
226 => 'IM Used',
// RFC3229
300 => 'Multiple Choices',
301 => 'Moved Permanently',
302 => 'Found',
303 => 'See Other',
304 => 'Not Modified',
305 => 'Use Proxy',
306 => 'Reserved',
307 => 'Temporary Redirect',
308 => 'Permanent Redirect',
// RFC-reschke-http-status-308-07
400 => 'Bad Request',
401 => 'Unauthorized',
402 => 'Payment Required',
403 => 'Forbidden',
404 => 'Not Found',
405 => 'Method Not Allowed',
406 => 'Not Acceptable',
407 => 'Proxy Authentication Required',
408 => 'Request Timeout',
409 => 'Conflict',
410 => 'Gone',
411 => 'Length Required',
412 => 'Precondition Failed',
413 => 'Request Entity Too Large',
414 => 'Request-URI Too Long',
415 => 'Unsupported Media Type',
416 => 'Requested Range Not Satisfiable',
417 => 'Expectation Failed',
418 => 'I\'m a teapot',
// RFC2324
422 => 'Unprocessable Entity',
// RFC4918
423 => 'Locked',
// RFC4918
424 => 'Failed Dependency',
// RFC4918
425 => 'Reserved for WebDAV advanced collections expired proposal',
// RFC2817
426 => 'Upgrade Required',
// RFC2817
428 => 'Precondition Required',
// RFC6585
429 => 'Too Many Requests',
// RFC6585
431 => 'Request Header Fields Too Large',
// RFC6585
500 => 'Internal Server Error',
501 => 'Not Implemented',
502 => 'Bad Gateway',
503 => 'Service Unavailable',
504 => 'Gateway Timeout',
505 => 'HTTP Version Not Supported',
506 => 'Variant Also Negotiates (Experimental)',
// RFC2295
507 => 'Insufficient Storage',
// RFC4918
508 => 'Loop Detected',
// RFC5842
510 => 'Not Extended',
// RFC2774
511 => 'Network Authentication Required',
// RFC6585
);
/**
* Constructs the Response object.
*
* @param string $content Content that will be attached to the response.
* @param int $statusCode HTTP status code that will be sent back to the user.
* @param array $headers Additional headers that should be attached to the response.
*/
public function __construct($content = '', $statusCode = 200, $headers = [])
{
$this->setContent($content);
$this->setStatusCode($statusCode);
$this->_headers = $this->arr($headers);
$this->_cacheControl = new CacheControl();
$this->_cacheControl->setAsDontCache();
}
/**
* Static constructor.
*
* @param string $content Content that will be attached to the response.
* @param int $statusCode HTTP status code that will be sent back to the user.
* @param array $headers Additional headers that should be attached to the response.
*
* @return Response
*/
public static function create($content = '', $statusCode = 200, $headers = [])
{
return new self($content, $statusCode, $headers);
}
/**
* Set response content.
*
* @param string $content Response content.
*
* @return $this
* @throws Response\ResponseException
*/
public function setContent($content)
{
if (!is_string($content)) {
throw new ResponseException('Response content must be a string.');
}
$this->_content = $content;
return $this;
}
/**
* Get response content.
*
* @return string
*/
public function getContent()
{
return $this->_content;
}
/**
* Set HTTP response status code. The status code must be a valid HTTP status code, or an exception will be thrown.
*
* @param int $statusCode Http status code.
* @param string $message Http status message. If not set we will use the default message by RFC2616.
*
* @return $this
* @throws Response\ResponseException
*/
public function setStatusCode($statusCode, $message = '')
{
if (empty($message)) {
if (!isset(self::$httpStatuses[$statusCode])) {
throw new ResponseException('Invalid status code provided: "' . $statusCode . '".');
} else {
$this->_statusMessage = self::$httpStatuses[$statusCode];
}
} else {
$this->_statusMessage = $message;
}
$this->_statusCode = $statusCode;
return $this;
}
/**
* Returns current status code.
*
* @return int
*/
public function getStatusCode()
{
return $this->_statusCode;
}
/**
* Sets the Content-Type header value.
*
* @param string $contentType
*
* @return $this
*/
public function setContentType($contentType)
{
$this->_contentType = $contentType;
$this->setHeader('Content-Type', $contentType . '; charset=' . $this->getCharset());
return $this;
}
/**
* Returns the currently set content type.
*
* @return string
*/
public function getContentType()
{
return (isset($this->_contentType) ? $this->_contentType : self::CONTENT_TYPE);
}
/**
* Set the response charset.
*
* @param string $charset Charset name.
*
* @return $this
*/
public function setCharset($charset)
{
$this->_charset = $charset;
$this->setContentType($this->getContentType()); // update charset which is set on content-type
return $this;
}
/**
* Returns currently set response charset.
*
* @return string
*/
public function getCharset()
{
return (isset($this->_charset) ? $this->_charset : self::CHARSET);
}
/**
* Sets or adds a header.
*
* @param string $key Header name.
* @param string $value Header value.
*
* @return $this
*/
public function setHeader($key, $value)
{
$this->_headers->key($key, $value);
return $this;
}
/**
* Returns an array of current headers.
*
* @return array
*/
public function getHeaders()
{
return $this->_headers->val();
}
/**
* Sets the response as not modified.
*
* @return $this
*/
public function setAsNotModified()
{
$this->setStatusCode(304);
$this->setContent('');
// remove headers that MUST NOT be included with 304 Not Modified responses
$headersToRemove = [
'Allow',
'Content-Encoding',
'Content-Language',
'Content-Length',
'Content-MD5',
'Content-Type',
'Last-Modified'
];
foreach ($headersToRemove as $header) {
$this->_headers->removeKey($header);
}
return $this;
}
/**
* Get access to cache control headers.
*
* @return CacheControl
*/
public function cacheControl()
{
return $this->_cacheControl;
}
/**
* Send the currently defined headers.
* This also sends the cache control headers.
*
* @return $this
*/
public function sendHeaders()
{
// first build headers -> only if they haven't already been sent
if (!headers_sent()) {
// status code header
header(self::PROTOCOL . ' ' . $this->getStatusCode() . ' ' . $this->_statusMessage
);
// other headers
foreach ($this->_headers as $k => $v) {
header($k . ': ' . $v);
}
// cache control headers
$cacheControlHeaders = $this->_cacheControl->getCacheControl();
foreach ($cacheControlHeaders as $k => $v) {
header($k . ': ' . $v);
}
}
return $this;
}
/**
* Sends the content to the browser.
*
* @return $this
*/
public function sendContent()
{
echo $this->_content;
return $this;
}
/**
* Sends both the headers and the content to the browser.
*
* @return $this
*/
public function send()
{
$this->sendHeaders()->sendContent();
// close the request
if (function_exists('fastcgi_finish_request')) {
fastcgi_finish_request();
} elseif (strtolower(PHP_SAPI) != 'cli') {
ob_end_flush();
}
return $this;
}
}